Services partial outage
Incident Report for Faria Education Group
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 08:16 UTC
Monitoring
Cloudflare has global issues which affect many customers including us.
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2022 - 07:20 UTC
Investigating
CloudFlare has global issues which affect many customers including us
Posted Jun 21, 2022 - 06:55 UTC
This incident affected: OpenApply (OpenApply Global, OpenApply USA), ManageBac (ManageBac Global, ManageBac USA), and Keybridge.