OpenApply Unscheduled maintenance

Incident Report for Faria Education Group

Resolved

This incident has been resolved.
Posted Nov 18, 2022 - 08:41 UTC

Identified

OpenApply is performing the unscheduled maintenance at the moment, sorry for the inconvenience.
Posted Nov 18, 2022 - 07:35 UTC
This incident affected: OpenApply (OpenApply China).