We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 15:22 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 13:07 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:56 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:21 UTC
Monitoring
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:19 UTC
Investigating
We are currently experiencing intermittent access issues in some regions due to a Cloudflare service disruption. Our team is monitoring the situation. We will provide further updates as they become available. Apologies for the inconvenience.
Posted Nov 18, 2025 - 12:01 UTC
This incident affected: OpenApply (OpenApply Global, OpenApply USA, OpenApply Europe), Accounts Portal, SchoolsBuddy, Atlas, AtlasNext, Pamoja Education, OSC Study, Wolsey Hall, Oxford, and ManageBac (ManageBac Global, ManageBac USA).