ManageBac is down
Incident Report for Faria Education Group
Resolved
This incident has been resolved.
Posted Feb 12, 2020 - 15:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2020 - 15:41 UTC
Identified
We have identified the cause of the outage and working with urgency to resolve the problem.
Posted Feb 12, 2020 - 15:40 UTC
Investigating
Apologies for the extended outage. Our hosting provider is investigating with urgency and we will update as soon as we know more.
Posted Feb 12, 2020 - 14:53 UTC
This incident affected: ManageBac (ManageBac Global).